The external disruption at the root of these issues appears to be resolved. Sites and services that were impacted, including 7shifts and Square's dashboard among many others, now appear to be working normally.
Posted Nov 18, 2025 - 08:52 CST
Update
Square's dashboard now appears to be impacted, with errors blocking signing in. Point of sale and other Square services are normal.
Posted Nov 18, 2025 - 08:10 CST
Update
7shifts appears to be impacted by this disruption now. Until this is resolved you may face issues signing into or using 7shifts. Due to the nature of the issue, we can expect similar issues with other sites and services until this is resolved.
Posted Nov 18, 2025 - 07:41 CST
Identified
There is an ongoing service disruption affecting many sites and services around the internet. Currently this does not seem to be directly impacting any of Colectivo's services, we can expect to see some websites struggle this morning.