With Square, we have identified the issue and rolled out a fix. We will be watching closely for any new issues before we close this out.
Posted Aug 06, 2025 - 13:58 CDT
Update
We are continuing to work with Square to resolve this.
Posted Aug 06, 2025 - 11:41 CDT
Investigating
We are seeing many reports of freezing and other disruptions on our POS across many locations today. We are investigating this and working with Square, and we will provide updates here as soon as we have news.
Posted Aug 06, 2025 - 08:20 CDT
This incident affected: Cafe Ordering System (Cafe POS and Expo, Customer App).