Uber's services appear to be returning to normal, and our Uber Eats ordering has been reenabled for all locations.
Posted Nov 18, 2025 - 11:49 CST
Investigating
We are noticing a service disruption with Uber Eats currently. As a precaution, Uber Eats ordering has been paused for all locations until this has been resolved.
Posted Nov 18, 2025 - 11:06 CST
This incident affected: Cafe Ordering System (Cafe POS and Expo, Customer App).